Page 1 of 1

Startup Issues And Their Solutions - Part 2

PostPosted: Sun 1. Jul 2012, 10:14
by Alien
This is a continuation of this thread: Startup Issues And Their Solutions viewtopic.php?f=21&t=11
I thought this thread and the original thread should be in Technical Discussion (and merged into one thread)

So here is some more info on how to solve some problems installing TOC

Uruexplorer / Urulauncher boots MOULa not TOC
The solution to this seems to be to uninstall TOC and reinstall it.
As I found in This Thread, CalRoger also found that was the solution.

Missing DLL's
Moderators Note: Normally the missing runtimes should be installed by the TOC Installer. If you still have problems please download and install the runtimes mentioned here. If this doesn't work you can follow Aliens instructions.
When you go to boot the TOC launcher, you get the message "xxxx.dll is missing"
Type the missing dll file into Google, one of the first results that comes up should be a link to
Look for that link in the results, and go to it. Click on the "Download Zip File" button.
Unzip the file and copy the dll to C:\Windows\System32
Do this for each dll file that is missing each time you try to start the TOC client.

If it helps you, here are the dll files I had to download :

MSVCP100.dll ... l?msvcp100
MSVCR100.dll ... l?msvcr100

xxxx.dll is not designed to work with Windows
You might get this :


Here is how I solved it :
1.) Delete the dll file it says is not designed to work with Windows. This must be done before the following :
2.) Download and install these :
If you have an option to repair, choose that.

3.) Launch the TOC client, it may look like the MOULa launcher at first, but should change to the TOC launcher.
It may download a huge update, depending on your internet speed, this may take a while

Some Other Useful Info
Install TOC-MOUL on OSX using Wine

TOC Repair Tool

I hope this helps you.
If you had a problem not listed and solved it or an alternate solution to that above, that worked for you,
please post it here. Make it clear, easy to read and step-by-step.

Suggestion to forum Mods / Admin : Please move the thread "Startup Issues and their Solutions" to Technical Discussion and merge the two threads
If someone could translate this into German, I would appreciate it, if it helps


Re: Starup Issues And Their Solutions - Part 2

PostPosted: Sun 1. Jul 2012, 11:38
by Mystler
Thank you! Stickied.

Re: Startup Issues And Their Solutions - Part 2

PostPosted: Mon 6. Nov 2017, 04:31
by Damiano93
This .dll issue seems to be quite stubborn: OpenAL321.dll is the .dll at hand and I have put it into Windows/System 32 countless times, updated NVIDIA PhysX, Legacy driver, installed the latest Microsoft Direct X etc. etc. and it still comes up as missing! I have resolved plenty of .dll issues before but this one is just plain stubborn. Any ideas? Thank you in advance!

Re: Startup Issues And Their Solutions - Part 2

PostPosted: Mon 6. Nov 2017, 09:16
by Damiano93
So, now the error message reads:

"The Procedure Entry Point alcCaptureOpenDevice could not be located in the dynamic link library OpenAL32.dll"

At least it finally found the .dll! I installed OpenAL to no's definitely a sound least that has been clear. Now it's snitting about one part of the .dll