Login    Register
  • Author
    Message

Re: Install TOC-MOUL on OS X Using Wine

Postby Korovev » Tue 2. Sep 2014, 23:46

I have these.
ImageImage
Ready-made shard wrappers, Wineskin guide, D’ni language notes, D’ni UCSUR font, DniTools
ReGalpo Rilesa téníen šemtí!
Korovev

User avatar
 
Posts: 29
Joined: Sun 20. Apr 2014, 19:17
MOULa KI#: 46116
TOC-MOUL KI#: 236871
TOC-TPOTS KI#: 55350
DI KI#: 194197
Gehn Shard KI#: 137074
Minkata KI#: 132812

Re: Install TOC-MOUL on OS X Using Wine

Postby Mystler » Wed 3. Sep 2014, 13:43

My point was that I believe your problem is not related to the TOC client, but here are the code changes:
https://github.com/TOC-Shard/Plasma/com ... a291ac7d82
Mystler
Development Manager

User avatar
 
Posts: 649
Joined: Mon 11. Jul 2011, 16:14
Location: Germany
Gender: Male
MOULa Name: Mystler
MOULa KI#: 150272
TOC-MOUL Name: Mystler
TOC-MOUL KI#: 346
TOC-TPOTS KI#: 0
DI KI#: 0
Gehn Shard KI#: 0
Minkata KI#: 0

Re: Install TOC-MOUL on OS X Using Wine

Postby Ainia » Fri 5. Sep 2014, 21:14

Greetings again,

Today I finally have time to try installing fresh with a blank wrapper. After adding the msvcr120.dll and msvcp120.dll files by hand (so the TOC-MOUL.exe file would run), I am getting this error, along with a failed install:

TOC Error
Update Failed: kNetErrFileNotFound
Data\dat\CustomAvatars_District_Bahro1.prp.gz
OK

I am interpreting this error to mean this file cannot be found on the server and so the installer errors out and quits. Has anybody else had this happen? Does anyone know how to resolve this? Is the file really missing or is something else going wrong here?

Just in case it's helpful, I'm posting the LastRunX11 and LastRunWine log files.

Spoiler:
WineskinX11: main(): argc=12
Waiting for startup parameters via Mach IPC.
WineskinX11: do_start_x11_server(): argc=12
Attempting to use pixel depth of 24
[1195341.805] WineskinX11 starting:
[1195341.805] X.Org X Server 1.13.0
[1195341.805] Build Date: 20120921
[1195341.805] _XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
[1195341.807] Initializing built-in extension Generic Event Extension
[1195341.807] Initializing built-in extension SHAPE
[1195341.807] Initializing built-in extension MIT-SHM
[1195341.807] Initializing built-in extension XInputExtension
[1195341.807] Initializing built-in extension XTEST
[1195341.807] Initializing built-in extension BIG-REQUESTS
[1195341.807] Initializing built-in extension SYNC
[1195341.807] Initializing built-in extension XKEYBOARD
[1195341.807] Initializing built-in extension XC-MISC
[1195341.807] Initializing built-in extension XINERAMA
[1195341.807] Initializing built-in extension PseudoramiX
[1195341.807] Initializing built-in extension XFIXES
[1195341.807] Initializing built-in extension RENDER
[1195341.807] Initializing built-in extension RANDR
[1195341.807] Initializing built-in extension DAMAGE
[1195341.807] Initializing built-in extension MIT-SCREEN-SAVER
[1195341.807] Initializing built-in extension DOUBLE-BUFFER
[1195341.807] Initializing built-in extension RECORD
[1195341.807] Initializing built-in extension X-Resource
[1195341.807] Initializing built-in extension XVideo
[1195341.807] Initializing built-in extension XVideo-MotionCompensation
[1195341.807] Initializing built-in extension GLX
[1195341.807] x: 0, y: 0, w: 1920, h: 1178
[1195341.822] (II) GLX: Initialized Core OpenGL GL provider for screen 0
[1195341.945] noPseudoramiXExtension=0, pseudoramiXNumScreens=1
Engine Used: WS9Wine1.7.18
Hardware:

Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro8,3
Processor Name: Intel Core i7
Processor Speed: 2.5 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 16 GB
Boot ROM Version: MBP81.0047.B27
SMC Version (system): 1.70f6
Sudden Motion Sensor:
State: Enabled

Graphics/Displays:

Intel HD Graphics 3000:

Chipset Model: Intel HD Graphics 3000
Type: GPU
Bus: Built-In
VRAM (Total): 512 MB
VRAM (Dynamic, Max): 10
Vendor: Intel (0x8086)
Device ID: 0x0126
Revision ID: 0x0009
gMux Version: 1.9.24

AMD Radeon HD 6770M:

Chipset Model: AMD Radeon HD 6770M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6740
Revision ID: 0x0000
ROM Revision: 113-C0170L-573
gMux Version: 1.9.24
EFI Driver Version: 01.00.573
Displays:
Color LCD:
Display Type: LCD
Resolution: 1920 x 1200
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes

Spoiler:
fixme:ver:GetCurrentPackageId (0x32f1e4 0x0): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:RegisterTraceGuidsW (0x6ea19d, 0x0, {f7b697a3-4db5-4d3b-be71-c4d284e6592f}, 7, 0x75069c, (null), (null), 0x750ad0): stub
fixme:process:GetNumaHighestNodeNumber (0x32fbd8): semi-stub
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
fixme:ver:GetCurrentPackageId (0x33f7b8 0x0): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:advapi:RegisterTraceGuidsW (0x1007a19d, 0x0, {f7b697a3-4db5-4d3b-be71-c4d284e6592f}, 7, 0x100e069c, (null), (null), 0x100e0ad0): stub
fixme:process:GetNumaHighestNodeNumber (0x33f748): semi-stub
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
fixme:toolhelp:Heap32ListFirst : stub
err:winediag:init_driver_info Invalid GPU override 1002:6740 specified, ignoring.
fixme:win:EnumDisplayDevicesW ((null),0,0x33e80c,0x00000000), stub!
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
fixme:d3d:resource_check_usage Unhandled usage flags 0x8.
ImageImage
Ainia

User avatar
 
Posts: 10
Joined: Thu 28. Aug 2014, 02:01
Location: The Cleft, New Mexico
Gender: Female
MOULa Name: Ainia
MOULa KI#: 112888
TOC-MOUL Name: Ainia
TOC-MOUL KI#: 84076
TOC-TPOTS Name: Ainia
TOC-TPOTS KI#: 0
DI Name: Ainia
DI KI#: 136890
Gehn Shard Name: Ainia
Gehn Shard KI#: 41736
Minkata KI#: 0

Re: Install TOC-MOUL on OS X Using Wine

Postby Mystler » Thu 11. Sep 2014, 13:08

It is correct that the TOC client can not download that file because it is part of the original Myst Online client which we may not redistribute. I suggest you copy the specific files or, if you don't mind downloading TOC content again, the whole dat folder from MOULa.
Mystler
Development Manager

User avatar
 
Posts: 649
Joined: Mon 11. Jul 2011, 16:14
Location: Germany
Gender: Male
MOULa Name: Mystler
MOULa KI#: 150272
TOC-MOUL Name: Mystler
TOC-MOUL KI#: 346
TOC-TPOTS KI#: 0
DI KI#: 0
Gehn Shard KI#: 0
Minkata KI#: 0

Re: Install TOC-MOUL on OS X Using Wine

Postby Ainia » Thu 18. Sep 2014, 06:27

Shorah Mystler,

Had some time tonight to continue troubleshooting here and am finding that both my MOULa and Gehn wrappers do not contain any gzip files in their dat folders. I have CustomAvatars_District_Bahro1.prp in both, for instance, but not CustomAvatars_District_Bahro1.prp.gz. Just in case, I copied all my MOULa dat files into the TOC dat folder and tried to re-run TOC with pretty much the same results as before (although the error is now for CustomAvatars_District_Blake.prp.gz.

Any other ideas for what I should try?
ImageImage
Ainia

User avatar
 
Posts: 10
Joined: Thu 28. Aug 2014, 02:01
Location: The Cleft, New Mexico
Gender: Female
MOULa Name: Ainia
MOULa KI#: 112888
TOC-MOUL Name: Ainia
TOC-MOUL KI#: 84076
TOC-TPOTS Name: Ainia
TOC-TPOTS KI#: 0
DI Name: Ainia
DI KI#: 136890
Gehn Shard Name: Ainia
Gehn Shard KI#: 41736
Minkata KI#: 0

Re: Install TOC-MOUL on OS X Using Wine

Postby Mystler » Fri 19. Sep 2014, 17:16

Right, the files are zipped when downloaded from the fileserver. prp.gz means prp on your system.
If you still get that message, the file is either missing or recognized as outdated by the server.
Mystler
Development Manager

User avatar
 
Posts: 649
Joined: Mon 11. Jul 2011, 16:14
Location: Germany
Gender: Male
MOULa Name: Mystler
MOULa KI#: 150272
TOC-MOUL Name: Mystler
TOC-MOUL KI#: 346
TOC-TPOTS KI#: 0
DI KI#: 0
Gehn Shard KI#: 0
Minkata KI#: 0

Re: Install TOC-MOUL on OS X Using Wine

Postby Ainia » Fri 19. Sep 2014, 18:50

If that's really the case, then I am stuck and have no idea what to try next. My MOULa install is current, yet the TOC server seems to disagree, at least concerning the dat files.

In which case I don't seem to have much choice except giving up. *sigh* Maxxie will have to fend for himself...
ImageImage
Ainia

User avatar
 
Posts: 10
Joined: Thu 28. Aug 2014, 02:01
Location: The Cleft, New Mexico
Gender: Female
MOULa Name: Ainia
MOULa KI#: 112888
TOC-MOUL Name: Ainia
TOC-MOUL KI#: 84076
TOC-TPOTS Name: Ainia
TOC-TPOTS KI#: 0
DI Name: Ainia
DI KI#: 136890
Gehn Shard Name: Ainia
Gehn Shard KI#: 41736
Minkata KI#: 0

Re: Install TOC-MOUL on OS X Using Wine

Postby boblishman » Fri 19. Sep 2014, 23:48

Ainia wrote:
If that's really the case... I don't seem to have much choice except giving up...


whoaaaaaaaaa ... that's not the kind of talk we usually hear from an Explorer!! ... :shock:

OK. I have a suggestion: When then install "fails" because of a .gz file ... pop over to your current MOULa dat folder, copy it and then paste it into your TOC MOUL dat folder ... and run the installer again. Yes, it's tedious, but then so are some of the puzzles in Uru ... !

I remember having something similar happen to me when I was installing one of the shards (I don't remember which one off hand ...possible one of the "secret" ones ;) ) ... and I had to copy over the .prp versions of the "bad" .gz files ... but in actual fact, it turned out only to be about 9 or 10 files in total ... and then I was "in", up and running... :roll:

If Uru taught us anything it was surely ... perseverance ;)
boblishman

User avatar
 
Posts: 17
Joined: Wed 4. Jun 2014, 18:29
Location: Spain (but from UK originally)
Gender: Male
MOULa Name: boblishman
MOULa KI#: 0
TOC-MOUL Name: boblishman2
TOC-MOUL KI#: 0
TOC-TPOTS Name: boblishman
TOC-TPOTS KI#: 0
DI Name: boblishman
DI KI#: 0
Gehn Shard Name: boblishman
Gehn Shard KI#: 0
Minkata KI#: 0

Re: Install TOC-MOUL on OS X Using Wine

Postby Korovev » Sat 20. Sep 2014, 09:54

Just to be sure, you could try coping the dat and sfx folders from the Gehn shard instead of MOULa. Also, I needed msvcp110.dll and msvcr110.dll too to make TOC work.
ImageImage
Ready-made shard wrappers, Wineskin guide, D’ni language notes, D’ni UCSUR font, DniTools
ReGalpo Rilesa téníen šemtí!
Korovev

User avatar
 
Posts: 29
Joined: Sun 20. Apr 2014, 19:17
MOULa KI#: 46116
TOC-MOUL KI#: 236871
TOC-TPOTS KI#: 55350
DI KI#: 194197
Gehn Shard KI#: 137074
Minkata KI#: 132812

Re: Install TOC-MOUL on OS X Using Wine

Postby Ainia » Thu 25. Sep 2014, 17:10

boblishman wrote:
Ainia wrote:
If that's really the case... I don't seem to have much choice except giving up...


whoaaaaaaaaa ... that's not the kind of talk we usually hear from an Explorer!! ... :shock:

OK. I have a suggestion: When then install "fails" because of a .gz file ... pop over to your current MOULa dat folder, copy it and then paste it into your TOC MOUL dat folder ... and run the installer again. Yes, it's tedious, but then so are some of the puzzles in Uru ... !

I remember having something similar happen to me when I was installing one of the shards (I don't remember which one off hand ...possible one of the "secret" ones ;) ) ... and I had to copy over the .prp versions of the "bad" .gz files ... but in actual fact, it turned out only to be about 9 or 10 files in total ... and then I was "in", up and running... :roll:

If Uru taught us anything it was surely ... perseverance ;)

Sorry, I'd already copied the entire MOUL dat folder contents into the TOC dat folder... If you are suggesting that I need to do this repeatedly ad nauseum, then I still see this whole process as basically broken (despite Mystler's opinion to the contrary). Plus, I find the notable lack of interest by the shard admins in helping to solve this problem most distressing.

Korovev wrote:Just to be sure, you could try coping the dat and sfx folders from the Gehn shard instead of MOULa. Also, I needed msvcp110.dll and msvcr110.dll too to make TOC work.

I'd already copied the *110.dll and *120.dll files over. I will see about looking into using the Gehn shard dat files over the weekend when I will have a good chunk of time available. As I'd pretty much predicted, this is requiring a great deal of my time to sort out (and at this point, is fast becoming far more trouble than it's worth for me).
ImageImage
Ainia

User avatar
 
Posts: 10
Joined: Thu 28. Aug 2014, 02:01
Location: The Cleft, New Mexico
Gender: Female
MOULa Name: Ainia
MOULa KI#: 112888
TOC-MOUL Name: Ainia
TOC-MOUL KI#: 84076
TOC-TPOTS Name: Ainia
TOC-TPOTS KI#: 0
DI Name: Ainia
DI KI#: 136890
Gehn Shard Name: Ainia
Gehn Shard KI#: 41736
Minkata KI#: 0

PreviousNext

Return to Technical Discussion

Who is online

Users browsing this forum: No registered users and 1 guest